Header Ads

get-fans-468x60

URI online Judge Extremely Basic Problem 1002 | Area of a Circle | Solution by C / C++ Language

 URI Online Judge Problem solution

The formula to calculate the area of a circumference is defined as A = π . R2. Considering to this problem that π = 3.14159:
Calculate the area using the formula given in the problem description.

Input

The input contains a value of floating point (double precision), that is the variable R.

Output

Present the message "A=" followed by the value of the variable, as in the example bellow, with four places after the decimal point. Use all double precision variables. Like all the problems, don't forget to print the end of line after the result, otherwise you will receive "Presentation Error".
Input SamplesOutput Samples
2.00
A=12.5664
100.64
A=31819.3103
150.00
A=70685.7750
Solution by "C++" Language:

#include <iostream>
#include <iomanip>
using namespace std;
int main(){
    double R,A;
    cin>>R;
    A=R*R*3.14159;
    cout << fixed << setprecision(4)<<"A="<<A<<endl;
    return 0;
}

Solution by "C" Language: 

#include <stdio.h>
int main(){
    double R,A;
    scanf("%lf",&R);
    A=R*R*3.14159;
    printf("A=%.4lf\n",A);
    return 0;
} 


No comments

Powered by Blogger.